tjpcms欢迎你 tjpcms 一 最懂你的cms 联系作者
配置JDK、MyEclipse、Tomcat、Mysql
0次 0人次 0 2018-06-20

JDK:这个就不说了,不能再基础了,网上一搜一大把的,安装好配置下环境变量就行了,什么java -version,javac的输出试试。我目前用的版本是1.6的,好像有点老奥,主要一直没换过,时间长了就变老了,不过我用得挺好的,暂时也没打算换。版本如下:

blob.png

放个本地下载地址吧,不过估计下的有点慢,不行就自己百度个吧。jdk-6u24-windows-x64.zip

MyEclipse:之前用一个8.5的版本用了好久,后来好像是因为老是出现保存后没有自动发布的问题,就在那刷刷刷啊,刷不出来。手动点一下发布就刷出来了,这问题太影响效率了,很多时候不知道是自己问题没改好还是代码没发布出去,出现地还比较频繁,那段时间弄得我很是头疼这个问题。后来终于狠下心来,算了,升级。先试了2014,好不容易装好了,发现好像有点问题,上网一搜发现人家说2014有不少致命BUG,像是个过渡测试版,不建议用,没办法又换了2015,按照教程一步一步操作啊,终于装好了,需要crack一下,大家懂的。我现在的版本是2015 Stable 2.0,建议大家还是升级吧,这个版本我感觉蛮稳定的,我刚说的那个问题我就再也没遇到了,都是秒发布,改完保存,切换到浏览器一刷新就出来了,很爽。装2015的时候,还记得有个博客作者强调,说,按照我说的步骤一步一步操作肯定可以弄好,要是你没弄好,把步骤再仔细看一下。我一开始也是没搞定,看了他这话,只好又仔细看了几遍,果然发现我最后有个步骤弄错了,诚不我欺也。。

Tomcat:这个我用的是7.0.64,应该还算比较新的。最早的时候是用的7.0.39,虽然小版本号基本差不多,但其实我自己在用的过程中发现这两个版本还是有区别的,比如上传,还有一些说不上的地方,就是本来7.0.39是好好的,换成7.0.64后竟然就失效了,而且后台不报错,前台提示一个连接被重置的一个错误net::ERR_CONNECTION_RESET,好像是这个,反正是net::ERR开头的。弄得我一头雾水啊,不得已有些应用里又换回7.0.39了。只不过现在新的应用都用7.0.64了,上传那个错误也用了方法规避了,以后在技术分享里会写出来。然后在MyEclipse里配JDK和Tomcat,这个自行百度,也是一抓一大把,以前我不熟悉的时候这块配置也是感觉迷迷糊糊的,用多了发现了其实配置这些就是在MyEclipse里启动了你安装的那个Tomcat,自动运行了你安装的Tomcat的那些exe、bat之类,还有JDK也是用了你给的那个路径下的。总之最后开发调试时用的是你自己的JDK和Tomcat就行了,不要用MyEclipse自带的。

MySql:这个我用的好像也比较老了,用的是AppServ装的,版本是2510的64位版本。这个合成包好像是泰国的一个作者弄的,只不过这类合成安装包很多就是了,因为用php的人也是非常多的。这个包可以给你同时安装php、apache和MySql,也可以只装一个MySql了。安装教程,唉,百度百度,很多问题其实百度搜一下就知道了。装好了,再装个Navicat吧,建表、修改数据、赋权限什么的操作起来就方便多了,好像是分收费版和免费版,收费版的功能多一些,不过可以那什么,对吧。我用的版本是10.1.7,这个安装新一点的会更好。最后给个AppServ的下载链接吧,也可以百度搜版本号去找。appserv-win64-2.5.10_64位win7支持.rar

最后,这里其实只是大体笼统的说了一下环境的配置,在实际操作的过程中难免会遇到些问题,比如某些选项如何选啊、某些参数如何填啊这种,自行百度即可,最怕是你自己还没去研究研究先去问别人怎么办,其实你遇到的问题基本别人也都遇到过,会在网上提问,或者有人总结出来发到网上,你需要的就是耐心细致地去查阅、理解。所以这里只是给了一个结果,即最终都安装配置好了是什么效果,具体实施过程还需要自己去体会,只不过后续我会再发布一些具体操作的文章。

©2016-2019 www.tjpcms.com   苏ICP备16055273号-1